AppStore pense enfin aux utilisateurs avec une version iOS plus ancienne

Apple vient enfin de réagir pour rendre AppStore plus intelligent et convivial.

Antérieurement, si vous avez le malheur de ne pas suivre la cadence des sorties de nouveaux iPhone, iPad et iPod Touch ou des nouveaux firmwares vous deviez conserver précieusement sur votre ordinateur les app achetées avec iTunes au risque de les perdre.

Si une version plus récente non compatible avec le système d’exploitation de votre périphérique montrait son nez, vous n’aviez plus la possibilité de la réinstaller depuis AppStore. Il fallait obligatoirement passer par iTunes en USB et surtout avoir un .ipa dans sa bonne version. Sinon vous pouviez dire adieu la jolie petite app que vous aimiez tant !

Avec la sortie de iOS7 et le risque de voir AppStore claudiquer entre les apps compatibles iOS6 32-bit, iOS7 32-bit et iOS6 64-bit ou même des iOS nettement plus anciens allait rendre l’installation hasardeuse.

Autant dire que l’on s’éloignait de la philosophie Apple qui prévoit que l’utilisateur n’a pas trop à s’occuper de ce qu’il a sous le capot.

Dorénavant, vous pourrez avoir un iPhone 3GS sous iOS5 , un iPhone 4S sous iOS6 ou un iPhone 5C sous iOS7, AppStore s’occupera de vous rediriger vers la bonne version de l’app compatible avec votre matériel.

currentversion

Une grosse avancée pour ne plus perdre ses app sur ses anciens périphériques Apple à cause du temps qui passe.

Taggé avec: , , , , ,

1 Commentaire

  1. Très bonne et judicieuse nouvelle.

Laisser une réponse