ProblËme Safari

Mes applications officielles ne tournent plus rond pouvez vous m'aider ?

Modérateur: Mode&Rateurs

Règles du forum
[!] Si vous considérez votre problème comme réglé, merci de le signaler, un modérateur indiquera par une coche verte Image que votre problème est résolu.
4.13 iPod-728x90

Problème Safari

Messagepar le-lover74 » Ven 15 Jan 2010 10:56

BONJOUR à tous

Voila sans faire exprés j'ai déplacé MobileSafari.app (winscp privar/var/stash/application) dans un autre dossier d'application quelconque par le biais de winSCP.
Alors je L'ai copier sur mon pc(mobileSafari.app) puis supprimer dans winSCP afin de le remmettre dans privar/var/stash/application ( normale quoi )

Depuis safari ne s'ouvre plus plus du tout auriez vous une sollution sans tout resaturer ce qui m'est inconsevable ( j'ai redémarré l'iphone )

merci d'avance :-1
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar BonZ@i » Ven 15 Jan 2010 11:30

Il faut que tu remettes les droits en 755 avec Winscp
Passage chez les verts (SGSII)
Windows 7 x64/ MacBook pro 2011 os 10.7
Avatar de l’utilisateur
BonZ@i
Chef de Rang
 
Message(s) : 4580
Inscrit(e) le : Jeu 28 Fév 2008 16:54
Localisation : Nice

Re: Problème Safari

Messagepar Dualcore » Ven 15 Jan 2010 11:55

Ton Safari ne s'ouvrait plus car les droits du logiciel étaient corrompus par le transfert sur le PC.

La solution serait de remettre les bons droits et propriétaires pour MobileSafari.app
Cependant tu vas aussi avoir perdu un lien symbolique qui nécessaire à Safari, donc c'est assez galère avec cette méthode.

ou de l'installer depuis un .deb (voir pièce jointe)

ou de restaurer ;)

Depuis un terminal cela donnerai en ligne de commande pour une installation depuis un deb

1 - dézipper le deb
2 - Mettre le deb dézippé à la racine de l'iPhone
3 - faire depuis un Terminal
dpkg -i safari.deb
puis ENTER
4 - Rebooter l'iPhone

Lancer Safari

Par sécurité

Renommer temporairement le MobileSafari.app fraichement installé en MobileSafari.app.bak (sans le déplacer)
Aller dans Cydia et désinstaller le package safari (il est a la lettre M)
Après désinstallation du package depuis Cydia
Renommer MobileSafari.app.bak en MobileSafari.app

Et c'est pas plus compliqué que ça ;)

Edit : Note que le logiciel iFile en version enregistrée (disponible dans Cydia) permet d'installer facilement les fichiers archives de type .deb
Vous n’êtes pas autorisé(e) à consulter les fichiers insérés à ce message.
Renseignez votre Profil dans le Panneau de l'utilisateur en indiquant dans la signature votre configuration matérielle (iPhone et Ordinateur) - Pas fait = Pas d'aide ! - Merci de votre compréhension
Le forum de SOSiPhone est au format iPhone visitez le depuis votre iPhone !

Les demandes d'aide postées dans ma messagerie privée ne seront pas prises en considération
Avatar de l’utilisateur
Dualcore
Chef de Rang
 
Message(s) : 9979
Inscrit(e) le : Sam 01 Jan 2000 12:00
Localisation : Nowhere but Now Here

Re: Problème Safari

Messagepar le-lover74 » Ven 15 Jan 2010 15:41

Un grand merci

je crois que l'on aurait tout simplement pas pu mieux m'expliquer que sa ^^
Je vais essayer tout sa de suite
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar le-lover74 » Ven 15 Jan 2010 17:48

je crois que le .deb ne marche pas quand je fais la manipulation sa me met
"" dpkg: error processing safari.deb(--install)
cannot acces archive, no such file or directory
errors were encountered while processing : safari.deb """

quand je clique sur propriété de mobileSafari.app sa me met deja ""octal 0755""
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar Dualcore » Ven 15 Jan 2010 19:07

Tu tapes quoi exactement dans le Terminal ?
Tu es root ?

Tu as bien dézippé l'archive jointe ?

Code : Tout sélectionner
dpkg -i /safari.deb


Pour moi ça s'installe sans aucun problème depuis l'archive deb jointe.
Renseignez votre Profil dans le Panneau de l'utilisateur en indiquant dans la signature votre configuration matérielle (iPhone et Ordinateur) - Pas fait = Pas d'aide ! - Merci de votre compréhension
Le forum de SOSiPhone est au format iPhone visitez le depuis votre iPhone !

Les demandes d'aide postées dans ma messagerie privée ne seront pas prises en considération
Avatar de l’utilisateur
Dualcore
Chef de Rang
 
Message(s) : 9979
Inscrit(e) le : Sam 01 Jan 2000 12:00
Localisation : Nowhere but Now Here

Re: Problème Safari

Messagepar le-lover74 » Sam 16 Jan 2010 13:37

oui j'ai dézipper et j'ai mis le safari.deb dans la racine dans user
après dans le terminal je tape
su
alpine
dpkg -i safari.deb
et return et donc après apparait le message d'erreur. bizard j'ai déja installer des .deb de la mème manière et c'est censer marcher
as tu une idée :Marchi
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar Dualcore » Sam 16 Jan 2010 21:46

Curieux, je vais refaire le package quelque fois qu'il y ait eu un pbl au zippage.
Renseignez votre Profil dans le Panneau de l'utilisateur en indiquant dans la signature votre configuration matérielle (iPhone et Ordinateur) - Pas fait = Pas d'aide ! - Merci de votre compréhension
Le forum de SOSiPhone est au format iPhone visitez le depuis votre iPhone !

Les demandes d'aide postées dans ma messagerie privée ne seront pas prises en considération
Avatar de l’utilisateur
Dualcore
Chef de Rang
 
Message(s) : 9979
Inscrit(e) le : Sam 01 Jan 2000 12:00
Localisation : Nowhere but Now Here

Re: Problème Safari

Messagepar le-lover74 » Dim 17 Jan 2010 01:08

Ne te donne pas autant de mal ;-) C'est deja asser gentil comme sa de m'aider. Mais j'avous que le fait de plus avoir safari est vraiment très dérangant. ^^

Image
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar le-lover74 » Dim 17 Jan 2010 12:25

cela ne vient pas de ton zip car je ne peux installer aucune application en .deb sa me met le mème message

puis-je utiliser un autre terminal parce que la je suis à cour d'idées -:4
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43

Re: Problème Safari

Messagepar Moujib » Dim 17 Jan 2010 13:16

essai d'installer le deb depuis l'application iFile dispo sur Cydia.
iFile permet de parcourir toute l'arborescence de ton iphone et d'installer les packages en deb ainsi que d'autres fonctionnalités intéressantes .
On ne peut rien apprendre aux gens. On peut seulement les aider ‡ dÈcouvrir qu'ils possËdent dÈj‡ en eux tout ce qui est ‡ apprendre.[GalilÈe]
Renseignez nous sur votre profil dans le Panneau de l'utilisateur en indiquant dans la signature votre configuration matÈrielle (iPhone et Ordinateur)
Merci de votre comprÈhension
Avatar de l’utilisateur
Moujib
 
Message(s) : 501
Inscrit(e) le : Dim 17 Août 2008 08:42
Localisation : Tunis*Tunisie*

Re: Problème Safari

Messagepar le-lover74 » Dim 17 Jan 2010 17:03

enfin sa marche merci beaucoup :-6
firmware iPhone 3GS 16go fraichement achetÈ
WINDOWS 7
le-lover74
 
Message(s) : 14
Inscrit(e) le : Dim 27 Déc 2009 23:43




Retour vers Problèmes applications AppStore

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)